LimSee3 Help File

This document provides a basic help for LimSee3 v0.5.2. The document is derived from the v0.5.1 help file - new or modified items are marked as such. Some figures might be slightly out-of-date, as minor changes in the user interface were made since v0.5.

  1. Application Lifetime
  2. Asset Libraries
    1. Opening a library
    2. Viewing a library
    3. Organizing assets in a library
      1. Asset transfer functions
      2. Asset import functions
    4. Closing a library
  3. Document Authoring
    1. Opening a document
    2. Saving a document
    3. Closing a document
    4. Editing a document
  4. Slideshow Specifics
  5. User Interface Customization
    1. Resizing components
    2. Docking
    3. Accessibility
  6. Document Exporting [modified in 0.5.2]
    1. Export to SMIL
    2. Export to XHTML + Slidy [new in 0.5.2]
  7. Help
    1. Help menu
    2. Reference: keyboard shortcuts

Application Lifetime

When started, LimSee3 provides an empty interface, such as that on figure 1.1.

In fact, some output has already been produced as part of the internal logging system: this output is by default not visible, since it is of little interest to the user, but it may become important if a bug is submitted to the developing team. The log console can be brought forth with the bottom-left button (fig. 1.2). (The log console is "iconified" at startup: see section 5.2 for more details.)

LimSee3 can be exited in two main ways, which are equivalent. Either the user closes the application window (usually by the upper-right "x" button) or (s)he uses the Quit command in the File menu. The latter can also be reached with the Ctrl+Q shortcut.

Initial screen

Fig. 1.1 - Initial screen

Log console

Fig. 1.2 - Log console with zoomed opening button and a part of the content

Asset Libraries

Media libraries allow users to organize the assets they (intend to) use into logical sets. A library is stored in an XML file, which has indifferently a .xml or a .xll extension. A library file merely describes actual media assets (their location, format, etc.), but the medias themselves are not stored in the library. This choice has several consequences:

It is possible to use several libraries at once.

Opening a library

An existing library can be opened via the File menu, item Open media library (or by using the Ctrl+L shortcut). Either way brings up a dialog window in which the user can choose one or several library files on the local machine. The selected libraries are then opened.

It is possible to create a new library from the File menu, item New library. The user is prompted for the mandatory name of the library, then an empty library is created. Choose a short but descriptive name for your library, since it will appear in the title bar, to ease quick toggling between libraries.

Viewing a library

There are three different manners of displaying the contents of a media library:

The actual mode can be chosen thanks to the three trailing icons of the library toolbar (fig. 2.1). Figure 2.2 presents example of the three different views of a library.

View switches

Fig. 2.1 - View switches

Example simple list view Example detailed list view Example snapshot view

Fig. 2.2 - Different views - a) simple list view, b) detailed list view (the window has been resized), c) snapshot view

Organizing assets in a library

Several functions are defined for manipulation of assets in a library. They can be split into two categories:

Asset transfer functions

Assets can be freely transferred between libraries and documents: it is possible to copy an asset in a library and put it into another library or a document; in the same way, an asset can be copied from a document and inserted into a library or a document.

The central part of a library toolbar (fig. 2.3) provides buttons for asset copying and pasting, which work in the same way as in any other editor: after selecting asset(s), press the Copy button, then choose a target location and invoke Paste on the target. In addition to the copy&paste commands, LimSee3 supports also the drag&drop mouse gesture: select asset(s) for copying, press mouse button, drag the asset(s) to their target location and release the mouse.

Transfer commands

Fig. 2.3 - Copy and paste commands

One asset can be selected by a simple click. To select several assets, hold the Ctrl key while selecting.

Asset import functions

The leading toolbar icons (fig. 2.4) allow to import new assets and erase existing ones. Notice that these actions concern the current library only, not the (physical) assets themselves: erasing an asset removes it from the library, not from the disc; importing a distant asset does not have it downloaded.

Import commands

Fig. 2.4 - Import and delete commands

Closing a library

A library can be closed either explicitly by closing the graphical component that offers a view onto it, or implicitly by closing the whole application. In either case the user is asked whether (s)he wants to save the changes to the library. If the library is a whole new one, the user is also prompted for the file name.

Document Authoring

Document authoring is the heart of LimSee3. This section will evolve continuously with future releases, since the main theoretical and practical effort goes here. Thus, it is important to be sure to read this section in the help document concerning your version of LimSee3 - this one concerns version 0.5.

LimSee3 documents are XML files having indifferently a .xml or a .xld extension. In the same way as media libraries, LimSee3 documents do not contain media assets, they merely refer to them. In this way, LimSee3 documents are kept (relatively) small and

It is possible to work on several documents at a time.

Opening a document

An existing document can be opened via the File menu, item Open document (or by using the Ctrl+O shortcut). Either way brings up a dialog window in which the user can choose one or several document files on the local machine. The selected documents are then opened.

It is currently not possible to create a whole new document in LimSee3. Instead, you can open an (empty) template document and save it under a different name.

Saving a document

There are two saving commands, both situated in the File menu:

It is possible that in some cases the application is not able to determine which document is to be saved. In such a case, the user is warned. It should be sufficient to "click" somewhere on the document (or to make it "active" in any other way) and to retry the saving.

Closing a document

It is possible to close a document via the File menu, Close document item (shortcut: Ctrl+W) or by closing the dockable component representing the document on the screen (more information about this matter is in section 5.2). Upon closing, the user is asked whether (s)he desires to save the document first.

Editing a document

LimSee3 documents are based on templates: a template can be seen as a document with holes and the authoring process as a means of filling the holes with medias. Figure 3.1 shows an example of a template document (not instantiated), opened in LimSee3 together with a media library.

Empty template example

Fig. 3.1 - Example of a template document

Let us have a closer look at the template visualization. It is composed of several rectangular regions with different icons inside. Every region represents one "hole" or "place-holder" in the template that can be filled with a media asset. The kind of assets that can be used for a particular region is specified by the template and is depicted by the icons. Thus, for instance, the four main regions can receive an image, a video or a text (fig. 3.2). We can notice an "image" icon in the middle of the template that is partially hidden by other elements: it belongs to a region that is situated under the other regions and that features the background.

Empty template detail

Fig. 3.2 - Detail of the template, with its regions and descriptive icons

It is easy to instantiate a region of a template with an asset from the library: the user can either use a mouse gesture (drag&drop from library to the document or even from the document to the document) or a copy&paste action (those commands are accessible when right-clicking on a an asset, resp. a region).

Figure 3.3 presents the result of instantiation of the background and the main top-left region. Such a partially instantiated template is a typical example of a LimSee3 document - not a pure template, nor a pure instance, but somewhere in between. The document of fig. 3.3 can be saved on the disc, it can even be used later as a template for deriving other documents.

Example of partial instantiation

Fig. 3.3 - A partially instantiated template

Text is a special kind of media, since it can be directly created by the user. This is why the right-click on an empty region proposes (besides pasting a media) to start a new text. On figure 3.4, we show how the slide title can be edited: a new toolbar appears that allows to modify usual text attributes, such as color, size, alignment etc.

Example of text instantiation

Fig. 3.4 - Editing a text

Slideshow Specifics

Currently, only the slideshow template is provided for LimSee3. In this section, we briefly describe its specific features.

The slideshow template allows to create a presentation formed by several slides that are designed to be viewed in a sequence. As we shall see in the sequel, each slide has a title, two navigation buttons (previous and next) and can contain several media objects. The precise number and layout of these objects is further specified by the means of sub-templates. There are currently three sub-templates, allowing the user to choose between a "cover" slide (one main media object), a "low populated" slide (two media objects) and a "populated" one (four media objects).

An empty slideshow document (template) can be obtained here. When opened in LimSee3, the first (non-instantiated) slide and a dedicated slideshow toolbar are shown (fig. 4.1). In fact, the first (default) slide is described in more details on figure 3.2.

Empty slideshow

Fig. 4.1 - Empty slideshow

Of course, a slide-show would contain more than one slide. One can create more of them thanks to the slideshow toolbar. When adding a new slide, the user can decide where to insert it (before or after the current slide) and then, (s)he is given a choice of the sub-template to use (fig. 4.2, fig. 4.3). Our slideshow template proposes three different slide layouts, differing mainly in the number of central regions.

Slideshow sub-template choosing dialog

Fig. 4.2 - Dialog for choosing a sub-template

Slide-2 sub-template

Fig. 4.3 - Detail of the "slide-2" sub-template

User Interface Customization

LimSee3 provides several possibilities to customize its user interface. Currently, customization is not persistent, meaning that it is lost after exiting the application.

Resizing components

User interface components (as well as the whole application window) can be freely resized by mouse gestures.

Docking

Every component in the user interface comes with its own title bar. We call it "docking bar", since besides the title, it contains also several buttons allowing to further manipulate the component (see example of title bar buttons on fig. 5.1). The docking bar is mouse-aware, so that the whole component can be dragged&dropped into a different screen area. Mouse gestures also allow to organize components into tabs or to detach them altogether from the main work space. Moreover, the docking bar provides commands for minimizing and maximizing the components.

Docking bar

Fig. 5.1 - Docking bar

The actual collection of docking buttons can be different for some components. For instance, LimSee3 does not allow some interface components to be closed (because there is currently no way to bring them back if needed), so that these components have no Close button.

Iconify/de-iconify
A component can be iconified by the Undock button button: the component is removed from the workspace (possibly other components are resized, to make benefit from the liberated space) and an icon appears somewhere on the circumference of the workspace. The icon is labelled with the name of the iconified component. Its exact location depends on the nature of the component: for instance media libraries iconify to the left, the log console iconifies to the bottom,...

An iconified component can be temporarily brought back by clicking on the corresponding icon. This makes appear an overlaid window with the component contents in it. The window interacts with the user in a normal way (the component works as expected), but as soon as the mouse pointer leaves the window, it is closed (iconified). To permanently de-iconify an iconified component, use the Dock button button in the temporary window.

Several components can be iconified at a time. There are as many icons as iconified components.

Maximize/undo maximize
A component can be maximized via the Maximize button button: the component is resized so to fill the whole workspace. A maximized component can be restored to its previous size by the Restore size button button.

Maximizing is exclusive: only one component can be maximized at a time.

Detach/attach
Components can be detached from the workspace thanks to the Detach button button. A detached component is made "floating": it is put in a standalone window which can be resized and moved independently from the main workspace. (For moving the floating window, drag its upper border.)

A floating component can be re-attached to the workspace via the Attach button button. It is integrated to the workspace at the same place where it was befor detaching.

Several components can be detached at a time.

Close
The Close button button closes a component. The application does not ask for confirmation, but in case of components with an internal state (such as media libraries or documents), a Save action is proposed.

Accessibility

The media asset libraries provide a support for accessibility. The Bigger button and Smaller button buttons on the docking toolbar allow to increase or decrease the size of the rendered elements, icons, texts etc. (see fig. 5.2) This functionality allows users to adapt their workspace to their eyesight ability. Progressively, all other interface components will integrate this scaling possibility.

Minimum size Medium size Maximum size

Fig. 5.2 - Scaled renderings of an asset library

Document Exporting [modified in 0.5.2]

LimSee3 allows documents to be exported to other format. Currently, export is possible into SMIL 2.0 and into XHTML.

All exporting functions are accessible via the Export menu. Each function applies on the currently active document - if there is none, or if the application cannot determine which document should be considered as active, the user is warned.

Export to SMIL

There are three items in the Export menu which allow to export into SMIL:

  1. Export to SMIL (with help)
  2. Direct export to SMIL - texts as text
  3. Direct export to SMIL - texts as image

In fact, items 2. and 3. are only shortcuts to specific branches of the general export procedure (item 1.). When hesitating, choose 1., as the general procedure guides the user through the choices.

The main issue about exporting to SMIL is the status of texts. There is an alternative the user has to decide:

In case you choose to export texts as images, a new .png file is created for every text.

Export to XHTML + Slidy [new in 0.5.2]

The last item of the Export menu, "Export to XHTML - slidy" allows to transform a slideshow document into a web page (XHTML), viewable in any browser. The web page is linked with a third-party JavaScript library (called Slidy) which allows to view the document in a slideshow manner.

Currently, it is necessary to be on-line when viewing a Slidy document produced by LimSee3.

Help

Help menu

LimSee3 has a Help menu with two items:

Reference: keyboard shortcuts

Shortcut Action
Ctrl+O Open document
Ctrl+W Close document
Ctrl+S Save document
Ctrl+Shift+S Save document as...
Ctrl+L Open a media library
Ctrl+Q Quit application
F1 Help

Status of the document: last changed on 23rd july 2007. Copyright INRIA. Created by Jan Mikáč